QuickBooks Service Degradation

Incident Report for Ruddr

Resolved

Intuit has fully-restored QuickBooks services across North America. Ruddr customers that leverage the QuickBooks integration should be operating normally.
Posted Sep 02, 2026 - 11:07 UTC

Update

Intuit has its QBO service back online. But, unfortunately, the response time is very slow. This slowness could take several hours to clear up and we will continue monitoring.
Posted Sep 02, 2026 - 02:38 UTC

Update

QuickBooks has provided the following update, "Our engineering team has figured out the root cause of the issue and a fix is in deployment, we are already seeing recovery across our systems and soon the service will be fully restored. We'll share updates as they become available."

Hopefully Ruddr's access to QuickBooks will be restored shortly.
Posted Sep 02, 2026 - 01:23 UTC

Monitoring

Intuit is having service issues primarily in the United States and Canada. These issues are outside of Ruddr's control but impact the ability to create invoices, payments, credit notes, and vendor bills. We are monitoring the situation. You can view the QuickBooks status page here: https://status.quickbooks.intuit.com/
Posted Sep 01, 2026 - 22:12 UTC
This incident affected: Web Application and API.