Email service delivery

Incident Report for Ruddr

Resolved

The AWS outage has been resolved.
Posted Oct 20, 2025 - 23:00 UTC

Monitoring

Our email sending has stabilized, but AWS is continuing to have issues, so we are monitoring for any additional problems.
Posted Oct 20, 2025 - 14:13 UTC

Identified

We are currently experiencing issues primarily with periodic dropped emails as part of a global outage at AWS.
Posted Oct 20, 2025 - 07:00 UTC
This incident affected: Web Application.