Performance Issues

Incident Report for Ruddr

Resolved

We are seeing no more issues with invoices after the fix.
Posted Sep 15, 2025 - 20:28 UTC

Monitoring

A fix for invoice performance has been deployed.
Posted Sep 15, 2025 - 18:45 UTC

Investigating

We are investigating an issue with performance, specifically related to invoice line items.
Posted Sep 15, 2025 - 17:30 UTC
This incident affected: Web Application and API.