QuickBooks Online Integration Issue
Incident Report for Ruddr
Resolved
Connectivity issues seem to be resolved.
Posted Apr 02, 2024 - 16:51 UTC
Investigating
Intermittent QBO connectivity issues. Do not remove the QuickBooks Online integration.
Posted Mar 29, 2024 - 21:26 UTC
This incident affected: Web Application.